We're currently facing visual issues on the report page. Registered answers are temporarily not displayed immediately.
Incident Report for Netigate DE
Resolved
This incident has been resolved.
Posted Sep 01, 2023 - 16:48 CEST
Investigating
We are currently investigating this issue.
Posted Sep 01, 2023 - 10:23 CEST
This incident affected: Netigate Tool.