At the moment we have technical disturbances on our respondent page.
Incident Report for Netigate DE
Resolved
This incident has been resolved.
Posted Nov 18, 2022 - 12:46 CET
Update
We are continuing to investigate this issue.
Posted Nov 18, 2022 - 12:10 CET
Investigating
At the moment we have technical disturbances on our respondent page
Posted Nov 18, 2022 - 10:31 CET
This incident affected: Respondent view.