Urgent network maintenance by our provider Cleura at 14.30 CET

Incident Report for Netigate DE

Resolved

This incident has been resolved.
Posted Oct 17, 2025 - 15:34 CEST

Investigating

Dear customers,
We would like to inform you about urgent network maintenance by our provider, Cleura, scheduled for 14:30 CET today. More info can be found here https://status.cleura.cloud/maintenance-windows/54610
Posted Oct 17, 2025 - 14:28 CEST